50 likes | 162 Vues
The Java Critiquer: Incremental Development of Educational Critiquing Systems. Lin Qiu. Enter code. Manual critiquing. Return code. Automatic critiquing. Review critiques. int x;. Use more descriptive variable names. public void increaseRadius() { radius = radius + 1;
E N D
The Java Critiquer: Incremental Development of Educational Critiquing Systems Lin Qiu
Enter code Manual critiquing Return code Automatic critiquing Review critiques int x; Use more descriptive variable names. public void increaseRadius() { radius = radius + 1; diameter = radius*2; } public boolean isValid() { if (radius > 0) return true; else return false; } Java has a simpler way to write this. Use ++radius; Don't cram things together without spaces, ex. x+y*z You never need to write an if to return true in one case and false in the other. Just write return (radius >0); instead.
Human Critiquer Critiquing System Incremental authoring Add a critique Realize Collect critiques Critique Authoring Refine the critique accumulating Familiarize Improve critiques Add a pattern Develop automation Generalize Pattern Authoring intelligence Refine the pattern Optimize Improve automation Share the critique and pattern Publicize Provide public access