SlideServe
Menu
Préférences
© SlideServe · v2026

IETF Standardisation Overview and integration of Internet standards

dakota-vinson avatar
29 diapositives · 427 Views · Oct 26, 2014

This presentation by Frederic Meunier, delivered in June 2006 in Brussels, provides an overview of the IETF's role in developing Internet standards through the RFC (Request For Comments) process. It discusses the lifecycle of RFCs, the revision and improvement of standards, and how to integrate these standards effectively. The Internet Society (ISOC), as a supporting organization, is also highlighted, including its mission, partnerships, and frameworks governing Internet standards. This informative session aims to clarify the collaborative processes involved in Internet governance and standardization.

IETF Standardisation Overview and integration of Internet standards - slide 1
01 / 29IETF Standardisation Overview and integration of Internet standards
1 / 17

Télécharger la présentation

IETF Standardisation Overview and integration of Internet standards
Une image / un lien ci-dessous est fourni (tel quel) pour télécharger la présentation

Politique de téléchargement : le contenu du site vous est fourni TEL QUEL pour votre information et votre usage personnel ; il ne peut être vendu, concédé sous licence ni partagé sur d’autres sites sans l’accord de son auteur.Le contenu vous est fourni TEL QUEL, pour votre information et votre usage personnel uniquement. Téléchargez la présentation en cliquant sur ce lien. Lors du téléchargement, si vous ne parvenez pas à télécharger une présentation, l’éditeur a peut-être supprimé le fichier de son serveur.Pendant le téléchargement, si vous ne parvenez pas à obtenir une présentation, le fichier a peut-être été supprimé par l’éditeur.

F I N

Plus de contenu associé

Transcription de la présentation
  1. IETF StandardisationOverview and integration of Internet standards • Speaker Frederic MEUNIER courtesy of TechnoMan Ingenierie • Organisation SOFREAVIA • Date and venue June 2006, Brussels

  2. IETF StandardizationSummary • ISOC organization : bodies and groups • Essence of IETF standards : RFCs • Lifecycle of an RFC • Revising / Improving standards • How to integrate RFC standards

  3. ISOC organisation • Internet SOCiety (ISOC) : • International NGO founded 1992 • Mission & Role : • Develop Internet related standards • Influence Public Policies on Internet governance • Promote and support education • Annual budget US$ 3 143 000 (2004)

  4. ISOC organisation • 20 000 individuals + 120 organizational members • Partners : • Regional Internet Registries • Internet Corporation for Assigned Names and Numbers (ICANN) • root server operators • Governments and groups (incl. UN) • ...

  5. ISOC organisation ISOC Architecture Management IAB Internet Advisory Board IESG Internet Engineering Steering Group Appeals board Area Directors Standards IETF Internet Engineering Task Force IANA Internet Assigned Numbers Authority

  6. ISOC organisation • IETF : • Funding comes from ISOC and working group members (meetings) • 8 functional areas managed by Area Directors from IESG • Application area • General area • Internet area • Operations and Management area • Real-time Applications and Infrastructure area • Routing area • Security area • Transport area « a loosely self-organized group of people »

  7. ISOC organisation • Working groups (actual technical work) : • A specific and reasonably achievable goal • Limited lifetime (short-lived) • Active participation makes you a Member : • You "join" the WG by subscribing to the mailing list • WG established at the initiative of an AD, an individual or a group of individuals : • Considered by AD and IESG • Charter negotiated between AD an WG • Approved by IESG (then IAB)

  8. ISOC organisation IETF Working Group Working Group […] Chair Chair Editor Editor Members Members "We reject kings, presidents and voting. We believe in rough consensus and running code."

  9. ISOC organisation • Relationship with other standardisation organisations : • no formal recognition • no submission to “traditional” bodies • Normalisation bodies can’t pre-empt RFC • Equal rights peers .

  10. IETF StandardizationSummary • ISOC organization : bodies and groups • Essence of IETF standards : RFCs • Lifecycle of an RFC • Revising / Improving standards • How to integrate RFC standards

  11. IETF Standards • RFC : Request For Comments • “above the wire and below the application” • Not all RFCs are standards

  12. IETF Standards • Types of RFC : • Informational (FYI) / Experimental / Historical • Best Current Practice (BCP) • Proposed Standard : • deploying implementation of such standards into a disruption-sensitive environment is not recommended • Draft standard : • at least two independent, interoperable implementations and sufficient successful operational experience exists • mature and final form of specification • Standard (STD) : • Numerous significant implementations and successful operational experiences

  13. IETF StandardizationSummary • ISOC organization : bodies and groups • Essence of IETF standards : RFCs • Lifecycle of an RFC • Revising / Improving standards • How to integrate RFC standards

  14. Lifecycle of an RFC • Goals of the Internet Standards Process: • technical excellence • prior implementation and testing • clear, concise, and easily understandable documentation • openness and relevance • timeliness • To bring balance with today's rapid development of networking technology

  15. Lifecycle of an RFC • « Who does what ? » • IESG : steering group • process management and RFC approval body • technical review & approves publication • Inter-WG technical coherence • IETF : technical work • RFC proposals • Seeking technical consensus

  16. Lifecycle of an RFC • The Internet Standards Process (RFC 2026) : • WG submits an Internet Draft • Technical reviewed by AD (against charter) • Reviewed by IESG board (eventually transmitted to IAB for advice) • RFC is then published

  17. Lifecycle of an RFC Working group doc, or individual standards track doc Area Director Submit Concerns IESG RFC Editor Published RFC “Last Call” Comments, suggestions IETF Community Review

  18. Lifecycle of an RFC • Finalisation of an RFC : • No formal vote • does not require unanimity • disputes resolved by discussion in mailing list and face-to-face meetings • final decisions is recorded on mailing list

  19. Lifecycle of an RFC • Publication : • Through RFC Editor : www.rfc-editor.org • Freely and widely available / accessible (no fees) • Drafts are available through www.ietf.org

  20. Lifecycle of an RFC • Intellectual Property Rights • A recurring concern • Some limited rights in all Contributions must be granted to the IETF and Internet Society • Defined in RFC 3978 et 3979

  21. IETF StandardizationSummary • ISOC organization : bodies and groups • Essence of IETF standards : RFCs • Lifecycle of an RFC • Revising / Improving standards • How to integrate RFC standards

  22. Improving standards • Once published, an RFC is NEVER revised • If the standard it describes changes, the standard will be re-published in another RFC that "obsoletes" the first • Some RFC may extend existing work • Some corporations submit their own documentation to the RFC repository

  23. Improving standards • Example : RTP (Real-Time Transport Protocol) • RFC1889 -> RFC3550 • Numerous additions to improve or extend the standard • example-RFC.html

  24. IETF StandardizationSummary • ISOC organization : bodies and groups • Essence of IETF standards : RFCs • Lifecycle of an RFC • Revising / Improving standards • How to integrate RFC standards

  25. How to integrate RFC standards • Some features may not be defined in RFC  Implement as you like ! • External reference to an RFC is supposed to be whole.

  26. How to integrate RFC standards • Defined glossary of terms (RFC2119) : • "MUST", "MUST NOT", • "REQUIRED", • "SHALL", "SHALL NOT", • "SHOULD", "SHOULD NOT", • "RECOMMENDED", • "MAY", • "OPTIONAL"

  27. How to integrate RFC standards • OSI Reference model and RFCs : APPLICATION PRESENTATION RFCs SESSION TRANSPORT NETWORK DATA LINK Mainly ISO, IEEE, ITU, ETSI, … PHY

  28. How to integrate RFC standards • Use the latest RFC : • Exclude obsolete documents • Updates and errata are supposed to be included • Be sure to check for important changes prior to referencing • Referencing through RFC number is enough • Include all needed related standards example-IP.htm

  29. IETF Standardization End