SlideServe
Menu
Préférences
© SlideServe · v2026

V6OPS WG – IETF #85 IPv6 for 3GPP Cellular Hosts

ivana avatar
7 diapositives · 216 Views · Aug 15, 2014

This draft outlines the motivation for updating RFC 3316, emphasizing the need to reflect recent developments in the 3GPP landscape. Key changes include the removal of outdated content, clarifications on the 3GPP link model, and new additions pertaining to IPv6 features and recommendations relevant to cellular hosts, such as support for DHCPv6 and router advertisement MTU options. The document aims to ensure a simple and conservative approach, facilitating better compliance and implementation in real-world scenarios.

V6OPS WG – IETF #85 IPv6 for 3GPP Cellular Hosts - slide 1
01 / 7V6OPS WG – IETF #85 IPv6 for 3GPP Cellular Hosts
1 / 17

Télécharger la présentation

V6OPS WG – IETF #85 IPv6 for 3GPP Cellular Hosts
Une image / un lien ci-dessous est fourni (tel quel) pour télécharger la présentation

Politique de téléchargement : le contenu du site vous est fourni TEL QUEL pour votre information et votre usage personnel ; il ne peut être vendu, concédé sous licence ni partagé sur d’autres sites sans l’accord de son auteur.Le contenu vous est fourni TEL QUEL, pour votre information et votre usage personnel uniquement. Téléchargez la présentation en cliquant sur ce lien. Lors du téléchargement, si vous ne parvenez pas à télécharger une présentation, l’éditeur a peut-être supprimé le fichier de son serveur.Pendant le téléchargement, si vous ne parvenez pas à obtenir une présentation, le fichier a peut-être été supprimé par l’éditeur.

F I N

Plus de contenu associé

Transcription de la présentation
  1. V6OPS WG – IETF #85IPv6 for 3GPP Cellular Hosts draft-korhonen-v6ops-rfc3316bis-00 Jouni Korhonen, Jari Arkko, Teemu Savolainen, Suresh Krishnan

  2. Outline • Motivation for RFC 3316bis • What has been changed • Removed from RFC 3316 • Clarifications on the existing text • New additions to RFC 3316 • Next steps

  3. Motivation for RFC 3316bis • RFC 3316 was done ~9 years ago, prior IPv6 Node Requirements; No need to repeat RFC 6434 (was RFC 4294) Node Requirements content. • Reflect recent 3GPP developments and experience. • Some IPv6 RFCs are not mandated by 3GPP but make sense e.g., in hosts with multiple interfaces. • Keep it simple and conservative. This is not a 3GPP document or a tool for driving deployment specific requirements!

  4. What has been changed – removed parts • Removal of all sections that can be directly found from RFC 6434 and do not require specific attention in 3GPP system: • IPv6 “basics”, PMTUD, IKE/IPsec, default address selection to name few..

  5. What has been changed – clarifications • Clarifications to 3GPP link model and how Neighbor Discovery works on it. • Previous text in RFC 3316 was sometimes misinterpreted.. • And there have been too many broken cellular host implementations and too strict GGSNs. • Already documented in RFC 6459 – endorsed here. • Clarification on the primary 3GPP IPv6 transition mechanism.. • ..which still is dual-stack. The rest are up to specific deployments. • Made the PPP IPV6CP support text conditional.

  6. What has been changed – new additions • Addition of 3GPP EPS text i.e., Release-8 and onwards. • Addition of RFC 4191 (router preferences) recommendations. • Addition of DHCPv6-based Prefix Delegation recommendations, which is new to 3GPP Release-10. • Addition of RFC 6106 (RDNSS) recommendations. • Addition of RFC 5555 (DSMIPv6) regarding client based mobility, which is new to 3GPP Release-8. • Addition of Router Advertisement MTU option handling. • Addition of RFC 5095 that deprecates the RH0. • Addition of RFC 5722 and draft-ietf-6man-nd-extension-headers regarding the IPv6 fragmentation handling. • Addition of RFC 6583 for Neighbor Discovery denial-of-service attack considerations.

  7. Next steps • Is there interest working on RFC 3316bis? • Adopt as a working group document..?