SlideServe
Menu
Préférences
© SlideServe · v2026

OSPFv3 Stub Router Advertisement

maris avatar
10 diapositives · 370 Views · Jul 05, 2012

OSPFv3 Stub Router Advertisement. draft- shishio - ospf - ospfv3 -stub. Shishio Tsuchiya shtsuchi@cisco.com Gunter Van de Velde gvandeve@cisco.com Tomohiro Yamagata to-yamagata@kddi.com. history. 00 - May 30, 2010 published

OSPFv3 Stub Router Advertisement - slide 1
01 / 10OSPFv3 Stub Router Advertisement
1 / 17

Télécharger la présentation

OSPFv3 Stub Router Advertisement
Une image / un lien ci-dessous est fourni (tel quel) pour télécharger la présentation

Politique de téléchargement : le contenu du site vous est fourni TEL QUEL pour votre information et votre usage personnel ; il ne peut être vendu, concédé sous licence ni partagé sur d’autres sites sans l’accord de son auteur.Le contenu vous est fourni TEL QUEL, pour votre information et votre usage personnel uniquement. Téléchargez la présentation en cliquant sur ce lien. Lors du téléchargement, si vous ne parvenez pas à télécharger une présentation, l’éditeur a peut-être supprimé le fichier de son serveur.Pendant le téléchargement, si vous ne parvenez pas à obtenir une présentation, le fichier a peut-être été supprimé par l’éditeur.

F I N

Plus de contenu associé

Transcription de la présentation
  1. OSPFv3 Stub Router Advertisement draft-shishio-ospf-ospfv3-stub Shishio Tsuchiya shtsuchi@cisco.com Gunter Van de Veldegvandeve@cisco.com Tomohiro Yamagata to-yamagata@kddi.com

  2. history • 00 - May 30, 2010 published • I have received a lot of feedbackcisco and KDDI internal. • 01 - Aug 28,2010 published • difference point of between 00 and 01 • add author Gunter Van de Velde gvandeve@cisco.com • correction of “R-bit” clear behaviors

  3. Problem statement • OSPFv3 has “no transit capability”,it is R-bit and v6-bit • OSPFv2 does not has “no transit capability” as the protocol,so most of venders supports RFC3137 as a technique. • OSPFv3 has same metric information field of all of LSAs(except of Link-LSA),so RFC3137 method can be adapted in OSPFv3.

  4. Problem statement cont’d • OSPFv3 should support both “R-bit,v6-bit” and “max-metric” as the protocol. • This draft described both methods to archive “OSPFv3 Stub Router advertisements”

  5. today’s OSPFv2 operation • RFC3137is informational RFC,but most of venders already support,anda lot of customer are using now. • Wait for time/BGP[RFC3137] • LDP IGPSyncronization [RFC5447] • configuration change [RFC3137]

  6. New Flow Of Traffic Primary Flow of Traffic OSPF Stub Router Advertisement OSPF Router can now be upgraded with minimal network interruption router ospf 123 max-metric router-lsa

  7. “R-bit,v6-bit” • RFC5340 Errata describe how to process “R-bit,V6-bit” http://www.rfc-editor.org/errata_search.php?rfc=5340&eid=2078 • If router supports “R-bit clear”,router should support wait for BGP or time same as RFC3137.

  8. OSPFv2 compatibility mode-max-metric- • OSPFv3 has metric information of all of LSAs(except of Link-LSA.)So,therouter can announce set to LSInfinity(0xFFFF). +-+-+-+--+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ | 0 |Nt|x|V|E|B| Options | +-+-+-+--+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ | Type | 0 | Metric | +-+-+-+--+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ | Interface ID | +-+-+-+--+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

  9. Summary • This draft does not require protocol enhancement • OSPFv3 should suport “R-bit clear” and “max-metric” as the protocol • The draft’s purpose is definition of both modes to avoid confusing for operators.

  10. Next Step • accept it is WG item? • informational or standard? • RFC3137 is informational RFC but • RFC3137 was published in 2001,and some vendors has been supported for 8 or 9 years. • A lot of customers are using in their commercial network. • There is some RFCs are referingRFC3137. such as RFC5443,RFC5286.RFC4970,RFC4915,RFC3277 • RFC3137 is stable and well-known. So I felt RFC3137 should be Standard.