SlideServe
Menu
Préférences
© SlideServe · v2026

Header Compression Schemes

rhoda avatar
21 diapositives · 424 Views · Sep 20, 2014

Header Compression Schemes. Different Header Compression schemes. Compressed TCP – Van Jacobsen RFC 1144 only for TCP/IP for wired networks Perkins improvement for of CTCP IPHC only for IP protocol no feedback. General Structure of Header Compressors.

Header Compression Schemes - slide 1
01 / 21Header Compression Schemes
1 / 17

Télécharger la présentation

Header Compression Schemes
Une image / un lien ci-dessous est fourni (tel quel) pour télécharger la présentation

Politique de téléchargement : le contenu du site vous est fourni TEL QUEL pour votre information et votre usage personnel ; il ne peut être vendu, concédé sous licence ni partagé sur d’autres sites sans l’accord de son auteur.Le contenu vous est fourni TEL QUEL, pour votre information et votre usage personnel uniquement. Téléchargez la présentation en cliquant sur ce lien. Lors du téléchargement, si vous ne parvenez pas à télécharger une présentation, l’éditeur a peut-être supprimé le fichier de son serveur.Pendant le téléchargement, si vous ne parvenez pas à obtenir une présentation, le fichier a peut-être été supprimé par l’éditeur.

F I N

Plus de contenu associé

Transcription de la présentation
  1. Header Compression Schemes

  2. Different Header Compression schemes • Compressed TCP – Van Jacobsen RFC 1144 • only for TCP/IP • for wired networks • Perkins • improvement for of CTCP • IPHC • only for IP protocol • no feedback

  3. General Structure of Header Compressors • Two entities: compressor and decompressor • Compressor sends initial base • Base is used by compressor and decompressor • Compressor removes redundancy • Decompressor adds removed information • Proposed solution differ in a possible feedback channel Base Base Decompressor Compressor N N N*

  4. CTCP (Van Jacobsen) • TCP/IP header compression • Using delta compression • Designed for wired networks • Not robust against error-prone links • Base update with each new incoming packet

  5. Loosing synchronization • Synchronization loss = decompressor’s copy of the base is different from the compressor’s copy • Synchronization is lost any time a packet is dropped • Detection: using detection of TCP retransmissions. All retransmissions are sent uncompressed

  6. Performance of VJ scheme in case of random errors Throughput of bulk data transfers File sizes of 344K, 328K, and 550K Kbytes/s S. J. Perkins and M. W. Mutka, Dependency Removal for Transport Protocol Header Compression over Noisy Channels. 1997. • When synchronization is lost, the decompressor starts to toss packets  base update more often than needed

  7. Perkins – Refinement of CTCP • Perkins & Mutka – improvement of CTCP in case of noise presence • Differentials are sent against a base that changes infrequently  packet loss does not cause endpoints to loose synchronization • All packets refer to the first packet of the frame • the same mechanisms can be used to detect loss of synchronization

  8. Perkins – Refinement of CTCP • Base refresh (sending uncompressed header) – to combat overflow problems • Robustness introduced by periodically repetition of full base information each N packets • N packets define a frame • Larger overhead • Less compression due to higher delta values • Additionally, 1 byte of CID (connection identifier) is transmitted

  9. Performance of Perkins scheme Throughput of bulk data transfers File sizes of 344K, 328K, and 550K S. J. Perkins and M. W. Mutka, Dependency Removal for Transport Protocol Header Compression over Noisy Channels. 1997.

  10. IP Header Compression (IPHC) • Provides extensions to VJ • Support UDP, IPv6, • Additional TCP features • Uses delta encoding

  11. TWICE algorithm • TCP header compression reduces throughput over lossy links • Bandwidth is wasted when unharmed segments are retransmitted after a timeout • Possible solutions: • Perkins algorithm • TWICE algorithm

  12. TWICE algorithm • Decompressor can detect loss of synchronization by using TCP checksum • Motivation: totally lossless HC is not possible, make an educated guess • If inconsistency is due to a single lost segment + lost segment increments the compression state in the same way  • Apply TWICE the delta of a current segment

  13. Compressed RTP (CRTP) • Compressed RTP (RFC 2508) • Compresses 40 byte header to 4 or 2 bytes • First-order changes • Expected changes in the fields that can be predicted, no transmission of differences needed • Second-order changes • Changes that have to be compressed • Enhanced Compressed RTP (RFC 3545) • Refinement of CRTP in presence of packet loss, reordering and long delays • Local retransmissions and repeated context updates are used

  14. Robust Checksum-based Compression (ROCCO) • Refinement of CRTP • Includes checksum over uncompressed header  facilitation of local recovery of the synchronization • Targeted to cellular usage

  15. Robust Header Compression • RTP/UDP/IP • UDP/IP • IP • uncompressed

  16. ROHC Modes

  17. States of Compressor and Decompressor

  18. Unidirectional

  19. Optimistic

  20. Reliable

  21. Decompressor