SlideServe
Menu
Préférences
© SlideServe · v2026

ARP - Address Resolution Protocol

aline-baldwin avatar
13 diapositives · 352 Views · Nov 09, 2014

ARP - Address Resolution Protocol. RFC 826. Motivation. Converting Protocol Addresses (e.g., IP addresses) to Local Network Addresses (e.g., Ethernet addresses). Protocol Type. Hardware Type. Opcode. HAL. PAL. Sender ’ s Hardware Address (HAL bytes).

ARP - Address Resolution Protocol - slide 1
01 / 13ARP - Address Resolution Protocol
1 / 17

Télécharger la présentation

ARP - Address Resolution Protocol
Une image / un lien ci-dessous est fourni (tel quel) pour télécharger la présentation

Politique de téléchargement : le contenu du site vous est fourni TEL QUEL pour votre information et votre usage personnel ; il ne peut être vendu, concédé sous licence ni partagé sur d’autres sites sans l’accord de son auteur.Le contenu vous est fourni TEL QUEL, pour votre information et votre usage personnel uniquement. Téléchargez la présentation en cliquant sur ce lien. Lors du téléchargement, si vous ne parvenez pas à télécharger une présentation, l’éditeur a peut-être supprimé le fichier de son serveur.Pendant le téléchargement, si vous ne parvenez pas à obtenir une présentation, le fichier a peut-être été supprimé par l’éditeur.

F I N

Plus de contenu associé

Transcription de la présentation
  1. ARP -Address Resolution Protocol RFC 826

  2. Motivation • Converting Protocol Addresses (e.g., IP addresses) to Local Network Addresses (e.g., Ethernet addresses)

  3. Protocol Type Hardware Type Opcode HAL PAL Sender’s Hardware Address (HAL bytes) Sender’s Protocol Address (PAL bytes) Target’s Hardware Address (HAL bytes) Target’s Protocol Address (PAL bytes) Opcode 1: ARP Request 2: ARP Reply HAL: Byte length of hardware address PAL: Byte length of protocol address

  4. RARP –Reverse Address Resolution Protocol RFC 903

  5. Motivation • Network hosts such as diskless workstations frequently do not know their protocol addresses when booted; they often know only their hardware interface addresses. • To communicate using higher-level protocols like IP, they must discover their protocol address from some external source.

  6. Protocol Type Hardware Type Opcode HAL PAL Sender’s Hardware Address (HAL bytes) Sender’s Protocol Address (PAL bytes) Target’s Hardware Address (HAL bytes) Target’s Protocol Address (PAL bytes) Opcode 3: Request Reverse 4: Reply Reverse HAL: Byte length of hardware address PAL: Byte length of protocol address

  7. InARP –InverseAddress Resolution Protocol RFC 1293

  8. Motivation • Allow a station to request a protocol address corresponding to a given hardware address.

  9. Protocol Type Hardware Type Opcode HAL PAL Sender’s Hardware Address (HAL bytes) Sender’s Protocol Address (PAL bytes) Target’s Hardware Address (HAL bytes) Target’s Protocol Address (PAL bytes) Opcode 8: InARP Request 9: InARP Reply HAL: Byte length of hardware address PAL: Byte length of protocol address

  10. ARP Parameters • Hardware Type • Operation Code  http://www.iana.org/assignments/arp-parameters