SlideServe
Menu
Préférences
© SlideServe · v2026

Alfonso López Murcia alfonso@dif.um.es

kyoko avatar
25 diapositives · 482 Views · Oct 24, 2014

Servicios basados en LDAP : Migración desde X.500. Alfonso López Murcia alfonso@dif.um.es. CONTENIDOS.  CARACTERISTICAS DE X.500 Y LDAP.  NUEVO ESQUEMA BASADO EN DOMINIOS.  PASO DE X.500 A LDAP.  NUEVOS SERVICIOS. EL DIRECTORIO X.500.  Protocolos OSI  Recomendaciones X.500

Alfonso López Murcia alfonso@dif.um.es - slide 1
01 / 25Alfonso López Murcia alfonso@dif.um.es
1 / 17

Télécharger la présentation

Alfonso López Murcia alfonso@dif.um.es
Une image / un lien ci-dessous est fourni (tel quel) pour télécharger la présentation

Politique de téléchargement : le contenu du site vous est fourni TEL QUEL pour votre information et votre usage personnel ; il ne peut être vendu, concédé sous licence ni partagé sur d’autres sites sans l’accord de son auteur.Le contenu vous est fourni TEL QUEL, pour votre information et votre usage personnel uniquement. Téléchargez la présentation en cliquant sur ce lien. Lors du téléchargement, si vous ne parvenez pas à télécharger une présentation, l’éditeur a peut-être supprimé le fichier de son serveur.Pendant le téléchargement, si vous ne parvenez pas à obtenir une présentation, le fichier a peut-être été supprimé par l’éditeur.

F I N

Plus de contenu associé

Transcription de la présentation
  1. Servicios basados en LDAP : Migración desde X.500 Alfonso López Murcia alfonso@dif.um.es

  2. CONTENIDOS  CARACTERISTICAS DE X.500 Y LDAP  NUEVO ESQUEMA BASADO EN DOMINIOS  PASO DE X.500 A LDAP  NUEVOS SERVICIOS

  3. EL DIRECTORIO X.500  Protocolos OSI  Recomendaciones X.500  Esquema X.521 basado en criterios geopolíticos  Trabajo de los servidores: “chaining”

  4. ESQUEMA X.521 root c C=UK C=ES C=PT o O=Empresa ou OU=Ventas OU=Marketing cn CN=Ana

  5. CONSULTA X.500 usuario DSA 1 O=Organización DSA 2 DSA 3 DSA 4 O=RedIRIS O=CICA O=UPC DIRECTORY ACCESS PROTOCOL (DAP) DIRECTORY SYSTEM PROTOCOL (DSP)

  6. ALTERNATIVA TCP/IP  Los protocolos OSI son pesados y poco eficientes  LIGHTWEIGHT DIRECTORY ACCESS PROTOCOL (LDAP), RFC 1777  Servidores LDAP

  7. CONSULTA LDAP usuario LDAP O=Organización DSA 2 DSA 3 LDAP O=RedIRIS O=CICA O=UNIRIOJA LIGHTWEIGHT DIRECTORY ACCESS PROTOCOL (LDAP)

  8. CONSULTA LDAPv3 usuario LDAP O=Organización LDAP DSA LDAP O=RedIRIS O=CICA O=UNIRIOJA LDAPv3 RFC 2251 - REFERENCIA

  9. CONSECUENCIAS  Sustituir servidores X.500 por LDAP  Como Internet se basa en dominios, pues vamos a reflejarlo en el Directorio: RFC 2377

  10. ESQUEMA RFC 2377 root domain dc=uk dc=es dc=com o dc=empresa ou OU=Ventas OU=Marketing cn/uid cn=Telefono uid=Ana

  11. LDIF ORGANIZACION dn: dc=empresa, dc=com objectclass: organization objectclass: dcObject objectclass: domainRelatedObject objectclass: labeledURIObject o: Empresa Familiar dc: empresa associatedDomain: empresa.com labeledURI: http://www.empresa.com Web Emp . . .

  12. ESPACIO DE NOMBRES (I) dc=com dc=empresa ou=Marketing ou=Ventas ou=Servicios Basado en la organización

  13. ESPACIO DE NOMBRES (II) dc=com dc=empresa ou=Dispositivos ou=Personas ou=Grupos Basado en los objetos

  14. ESPACIO DE NOMBRES (III) dc=com dc=empresa dc=ventas dc=soporte dc=ofertas Basado en dominios

  15. FORMATO ENTRADA dn: uid=ana, dc=empresa, dc=com objectclass: person objectclass: organizationalPerson objectclass: inetOrgPerson objectclass: account cn: Ana Romero Velázquez sn: Romero Velázquez mail: ana@empresa.com ou: mailing . . .

  16. MIGRACION  Elegir un espacio de nombres  Extraer entradas (LDIF) y volcarlas al servidor LDAP  Determinar restricciones Esquema mixto: o=organización,c=es dc=organización,dc=es

  17. MANTENIMIENTO REFERENCIAS  Referencias generadas a partir de registros SRV del DNS: _ldap._tcp.uni.es IN SRV 0 0 389 ldap.uni.es. producirá la referencia ldap://ldap.uni.es:389/

  18. ¿DEBO TENER UN SERVIDOR LDAP?  Certificados  Perfiles móviles (roaming)  Autenticación en UNIX  Autenticación en UNIX y Windows (no probado)

  19. ROAMING EN NETSCAPE (I)  El entorno del usuario en el navegador Netscape está en un servidor LDAP  Guía (OpenLDAP 1.2.x) http://www.um.es/~linux/ldap  Esquema incluido en 2.0.x

  20. ROAMING EN NETSCAPE (II) dn: ou=Roaming, dc=uni, dc=es objectclass: organizationalUnit ou: Roaming dn: cn=Profe Emerito, ou=Dept, dc=uni, dc=es objectclass: person cn: Profe sn: Emerito userpassword: secret dn: nsLIProfileName=Profe Emerito, ou=Roaming, dc=uni, dc=es objectclass: nsLIProfile owner: cn=Profe Emerito, ou=Dept, dc=uni, dc=es

  21. ROAMING EN NETSCAPE (III)

  22. AUTENTICACION EN UNIX (I)  PAM, utilidades PADL y RFC 2307 sustituimos NIS  Guía (OpenLDAP 1.2.x) http://www.um.es/~linux/ldap  Esquema incluido en 2.0.x

  23. AUTENTICACION EN UNIX (I) dn: uid=ana, dc=uni, dc=es uid: ana cn: Ana Romero Velazquez objectClass: account objectClass: posixAccount userPassword: {crypt}V479CQrvyweWQ loginShell: /bin/bash uidNumber: 500 gidNumber: 100 homeDirectory: /home/ana gecos: Ana Romero Velazquez

  24. VIAS FUTURAS Autenticación Windows y Unix. Howto de Ignacio Coupeau  Referencias en el DNS  Aumento de la seguridad  Colaboración con el Comité de Migración

  25. Gracias por su atención