Une image / un lien ci-dessous est fourni (tel quel) pour télécharger la présentation
Politique de téléchargement : le contenu du site vous est fourni TEL QUEL pour votre information et votre usage personnel ; il ne peut être vendu, concédé sous licence ni partagé sur d’autres sites sans l’accord de son auteur.Le contenu vous est fourni TEL QUEL, pour votre information et votre usage personnel uniquement.Téléchargez la présentation en cliquant sur ce lien.Lors du téléchargement, si vous ne parvenez pas à télécharger une présentation, l’éditeur a peut-être supprimé le fichier de son serveur.Pendant le téléchargement, si vous ne parvenez pas à obtenir une présentation, le fichier a peut-être été supprimé par l’éditeur.
F I N
Plus de contenu associé
Transcription de la présentation
EU NREN PKI Jan Meijer AARnet PKI / Access Federations Strategy Workshop 10 February 2010 Sydney
me • 1998-2007: SURFnet • CERT, security, PKI, systems engineering, e-voting • 2007-now: UNINETT • service development, storage, PKI
beautiful morning.... • 22 NRENs • 6 months • 12573 server certs • starting personal
ehr, no, we want • others not to read our mail • to know the sender is the sender • that, for documents, thanks • no reading of my credit card number • no reading of my health information • no reading of my passwords • log on to my internal web site
Feb 1993, RFC 1422 Privacy Enhancement for Internet Electronic Mail: Part II: Certificate-Based Key Management obsoletes RFC 1114 Mail Privacy: Key Management (1989)
Feb 1993, RFC 1422 The infrastructure specified in this document establishes a single root for all certification within the Internet, the Internet Policy Registration Authority (IPRA). The IPRA establishes global policies, described in this document, which apply to all certification effected under this hierarchy. Beneath IPRA root are Policy Certification Authorities (PCAs), each of which establishes and publishes (in the form of an informational RFC) its policies for registration of users or organizations. Each PCA is certified by the IPRA.
USA crypto exports <1996: International Traffic in Arms Regulation 1996: Export Administration Regulations (EAR) of the Department Commerce 31 Dec 1998: 56 bit without license 12 January 2000: Freedom to export source: Bert-Jaap Koops’ Crypto Law Survey http://rechten.uvt.nl/koops/cryptolaw/cls2.htm#us
Pretty Good Privacy Jun 5, 1991: PGP 1.0 Jan 18, 1996: Ståle Schumacher from Norway publishes PGP 2.63i…with help: Aug 1996: RFC1991, PGP Message Exchange Formats (FYI) Nov 1998: RFC2440, OpenPGP Message Format (STD)
~2000 • Netherlands qualified Digital Signature accreditation framework ready • SURFnet PKI: test audit
~2001 “SURFdiensten” GlobalSign discount deal for .nl higher ed
1998-2004: PKI evolves • Focus on policy • Focus on CA operations • Plans to interlink European PKIs • Separate eScience Grid PKI • TACAR • Experience but not large scale deployment
idea • join forces • contract commercial CA • flat-rate for the TERENA community • unlimited • NREN becomes RA • re-use existing contractual relations make it stupid to not secure your server with SSL
SCS timeline • Jan 2005: idea written up (TF-CSIRT!) • Feb 2005: presented at TF-EMC2 “the list” 20 kEUR • Summer 2005: reality + procedure check • September 2005: CfP • January 2006: GlobalSign contract
SCS: lessons learned • vested interests, existing services, strong opinions, policy devil.... • browser popup was the problem • certain level of control good • do what matters • good enough = good enough!
2007 • contract renewal with GlobalSign • start preliminary work with new CfP
new CfP, lessons learned • root coverage: browsers *and* other platforms • validity on contract end • ensuring future root coverage • end user interfaces • interface response times • describe certificate request processing • profiles • subjectAltName • multiple valid certificates • internationalisation • support • auditing • training • certificate lifetime
more lessons...optional reqs • alternative lifetimes • end user interface for renewal • per NREN branding • additional profiles • eScience Grid certificate support • API • wildcard certificates • OCSP • extensive reporting