SlideServe
Menu
Préférences
© SlideServe · v2026

IPv6 Working Group Agenda and Milestones from IETF57, Vienna - July 2003

vashon avatar
21 diapositives · 338 Views · Sep 09, 2014

The IPv6 Working Group met at IETF57 in Vienna, July 2003, under the chairs Bob Hinden and Margaret Wasserman. Key agenda items included document status updates, open issues related to IPv6 node requirements, MIBs, prefix delegation, and neighbor discovery proxies. Significant discussions involved unique local addressing, local addressing requirements, and the deprecation of site-local addressing. The meeting outlined milestones for various RFC submissions, including IPv6 addressing architecture and advanced socket APIs, with ongoing work documented for future meetings.

IPv6 Working Group Agenda and Milestones from IETF57, Vienna - July 2003 - slide 1
01 / 21IPv6 Working Group Agenda and Milestones from IETF57, Vienna - July 2003
1 / 17

Télécharger la présentation

IPv6 Working Group Agenda and Milestones from IETF57, Vienna - July 2003
Une image / un lien ci-dessous est fourni (tel quel) pour télécharger la présentation

Politique de téléchargement : le contenu du site vous est fourni TEL QUEL pour votre information et votre usage personnel ; il ne peut être vendu, concédé sous licence ni partagé sur d’autres sites sans l’accord de son auteur.Le contenu vous est fourni TEL QUEL, pour votre information et votre usage personnel uniquement. Téléchargez la présentation en cliquant sur ce lien. Lors du téléchargement, si vous ne parvenez pas à télécharger une présentation, l’éditeur a peut-être supprimé le fichier de son serveur.Pendant le téléchargement, si vous ne parvenez pas à obtenir une présentation, le fichier a peut-être été supprimé par l’éditeur.

F I N

Plus de contenu associé

Transcription de la présentation
  1. IPv6 Working Group IETF57 Vienna July 2003 Bob Hinden & Margaret Wasserman Chairs

  2. Monday Agenda (1930-2200) • Introduction and Agenda Bashing -- Bob Hinden (5 min) • Document Status and Priorities -- Bob Hinden (10 min) • Open Issues with IPv6 Node Requirements -- John Loughney (15 min) • Open Issues with IPv6 MIBs -- Brian Haberman (10 min) • Open Issues with Prefix Delegation Requirements -- Shin Miyakawa (10 min) • Bridge-like Neighbor Discovery Proxies -- Dave Thaler (15 min) • IPv6 Node Information Queries -- Bob Hinden (15 min) • IPv6 Socket API for source address selection -- Samita Chakrabarti (10 min)

  3. Thursday Agenda (0900-1130) • Introduction and Agenda Review -- Bob Hinden (5 min) • Link Name and Sequence Options for IPv6 Neighbor Discovery -- Naiming Shen (5 min) • Open Issues with Scoped Address Architecture -- Jinmei Tatuya (10 min) • Requirements for Local Addressing: • Local Addressing Requirements -- Tony Hain & Juha Wiljakka (20 min) • General Discussion of Local Addressing Requirements -- Chairs (30 min) • Unique Local IPv6 Unicast Addresses -- Bob Hinden (20 min) • Site-Local Deprecation Document Plan -- Christian Huitema (30 min)

  4. MILESTONES (1) Done Submit A Flexible method to manage the assignment of bits of an IPv6 address block to the IESG for Informational. Done Submit Flow Label specification to IESG for Proposed Standard. Jul 03 (Mar 03) Submit Prefix Delegation requirements and submit to IESG for Informational. Done Revise Aggregatable Unicast Addresses (RFC2374) to remove TLA/NLA/SLA terminology. Done (Apr 03) Draft on Proxy RA solution for prefix delegation. Oct 03 (Apr 03) Submit update to ICMPv6 (RFC2463) to be republished at Draft Standard. Jul 03 (Apr 03) Submit TCP MIB to IESG for Proposed Standard. Aug 03 (Apr 03) Submit IPv6 Node Requirements to IESG for Informational. Aug 03 (May 03) Submit Forwarding Table MIB to IESG for Proposed Standard. Aug 03 (May 03) Resubmit Node Information Queries to IESG for Proposed Standard. Sep 03 (May 03) Submit UDP MIB to IESG for Proposed Standard.

  5. MILESTONES (2) Aug 03 ( Jun 03) Submit IP MIB to IESG for Proposed Standard. Oct 03 (Jun 03) Submit Router Preferences, More-Specific Routes, and Load Sharing to IESG for Proposed Standard Dec 03 (Jun 03) Submit updates to Auto Configuration (RFC2462) and Neighbor Discovery (RFC2461) to be republished at Draft Standard. Dec 03 (Jun 03) Submit Update to Privacy Extensions for Stateless Autoconfiguration document (RFC3041) to the IESG for Draft Standard. Dec 03 (Jul 03) Submit Proxy RA to IESG for Proposed Standard. Sep 03(Jul 03) Submit Link Scoped IPv6 Multicast Addresses to IESG for Proposed Standard. Aug 03 Submit IPv6 Scoped Addressing Architecture to IESG for Proposed Standard DROP? (Aug 03) Submit update to IPv6 over PPP (RFC2472) to IESG for Draft Standard. Jan 04 Nov 03 Re-charter or close working group.

  6. PUBLISHED & APPROVALS • RFC’s Published • RFC 3316 “Internet Protocol Version 6 (IPv6) for Some Second and Third Generation Cellular Hosts” • RFC 3513 “Internet Protocol Version 6 (IPv6) Addressing Architecture” • RFC 3531 “A Flexible Method for Managing the Assignment of Bits of an IPv6 Address Block” • RFC 3542 “Advanced Sockets Application Protocol Interface (API) for IPv6” • IESG Approved • “IPv6 Global Unicast Address Format”

  7. Flow Label • Editor: Jarno Rajahalme • Status: In IETF Last Call • Milestone: DONE • Submit for PS • Open Issues: • None

  8. Global Unicast Addresses • Editor: Bob Hinden • Status: IESG Approved • Milestone: DONE • Submit for Info • Open Issues: • None

  9. Proxy RA • Editor: Dave Thaler • Status: New draft • Milestones: • Internet Draft - DONE • Submit to IESG for PS - JUL 03 • Update Milestone to DEC 03 • To be discussed in WG

  10. Prefix Delegation Requirements • Editor: Shin Miyakawa • Status: New draft in w.g. last call • Milestone: MAR 03 • Submit for Info • Update Milestone to JUL 03 • To be discussed in WG

  11. IPv6 MIBs -- TCP MIB • Editor: Rajiv Raghunarayan • Status: In w.g. last call • Milestone: APR 03 • Submit for PS • Update milestone to JUL 03 • Open Issues: • To be discussed in WG

  12. IPv6 Node Requirements • Editor: John Loughney • Status: New draft in w.g. last call • Milestone: APR 03 • Submit for Info • Update milestone to AUG 03 • Open Issues: • To be discussed in WG

  13. IPv6 MIBs -- Forwarding Table • Editor: Brian Haberman • Status: New draft in w.g. last call • Milestone: MAY 03 • Re-submit for PS • Update milestone to Aug 03 • Open Issues: • To be discussed in WG

  14. Node Information Queries • Editor: Matt Crawford • Status: New draft in w.g. last call • Milestone: MAY 03 • Re-submit for PS • Update milestone to Aug 03 • Open Issues: • To be discussed in WG

  15. IPv6 MIBs -- UDP MIB • Editor: John Flick • Status: Draft available after IETF • Milestone: MAY 03 • Submit for PS • Update milestone to SEP 03 • Open Issues: • N/A

  16. IPv6 MIBs -- IP MIB • Editor: Shawn Routhier • Status: In W.G. last call • Milestone: JUN 03 • Submit for PS • Update milestone to AUG 03 • Open Issues: • To be discussed in WG

  17. Default Router Preferences • Editor: Rich Draves • Status: AD Comments Received • Milestone: JUN 03 • Submit to IESG for PS • Update milestone to OCT 03 • Open Issues: • Split load balancing into separate document

  18. Link-Scoped Multicast • Editor: Jung-Soo Park • Status: WG Draft Available • Milestone: JUL 03 • Submit for PS • Update milestone to AUG 03 • Open Issues: • Ready for WG last call?

  19. Scoped Addressing Architecture • Editor: Jinmei Tatuya • Status: WG Draft Available • Milestone: AUG 03 • Submit for PS • Open Issues: • To be discussed in WG • Ready for w.g. last call?

  20. Site-Local Limits • Editor: (Chairs) • Status: • WG consensus to deprecate site-local • Requirements and Local addressing drafts available • Milestone: None • Add milestones • Open Issues: • To be discussed in WG

  21. Work Not Started • ICMP Update • Autoconfiguration Update • Neighbor Discovery Update • Privacy Extensions Update • PPPv6 Update (Drop?) • IPv6 Addressing Architecture to DS • Add milestone NOV 03