SlideServe
Menu
Préférences
© SlideServe · v2026

Intro. to Networks

chill avatar
23 diapositives · 407 Views · Sep 25, 2014

Intro. to Networks. This lecture will consist Internet and Ethernet short history Layer model (ISO and IP) Routing and routers Linux routing table PPP short history and purpose PPP and Linux. Internet & Ethernet Brief history. Internet (http://www.isoc.org/internet/history/)

Intro. to Networks - slide 1
01 / 23Intro. to Networks
1 / 17

Télécharger la présentation

Intro. to Networks
Une image / un lien ci-dessous est fourni (tel quel) pour télécharger la présentation

Politique de téléchargement : le contenu du site vous est fourni TEL QUEL pour votre information et votre usage personnel ; il ne peut être vendu, concédé sous licence ni partagé sur d’autres sites sans l’accord de son auteur.Le contenu vous est fourni TEL QUEL, pour votre information et votre usage personnel uniquement. Téléchargez la présentation en cliquant sur ce lien. Lors du téléchargement, si vous ne parvenez pas à télécharger une présentation, l’éditeur a peut-être supprimé le fichier de son serveur.Pendant le téléchargement, si vous ne parvenez pas à obtenir une présentation, le fichier a peut-être été supprimé par l’éditeur.

F I N

Plus de contenu associé

Transcription de la présentation
  1. Intro. to Networks This lecture will consist • Internet and Ethernet short history • Layer model (ISO and IP) • Routing and routers • Linux routing table • PPP short history and purpose • PPP and Linux

  2. Internet & Ethernet Brief history Internet (http://www.isoc.org/internet/history/) • 1969 – ARPANET (The Internet origin) • 1969 – UNIX • 1972 – Ethernet • 1989 – WWW • 1991 – Linux • 1992 –Mosaic

  3. Internet organization • ISOC – http://www.isoc.org • IETF – http://www.ietf.org • IETF RFCs – http://www.ietf.org/rfc • IANA – http://www.iana.org • IAB – http://www.iab.org • W3C – http://www.w3c.org

  4. Other org. involve in Networks • ISO – http://www.iso.ch • ITU – http://www.itu.int • IEEE – http://www.ieee.org

  5. IP Ethernet hardware Ethernet IP stack TCP/UDP stack IP applications OSI layers via Internet layers OSI • Physical • Data link • Network • Transport • Session • Presentation • Application

  6. LAN MAC Addresses • Registration through the IEEE. • XX-XX-XX-XX-XX-XX • Vendor register leading XX-XX-XX. • Example: 3Com register 00-05-1A • Example: a NIC made by 3Com • 00-05-1A-0C-01-93

  7. Making LAN We need 4 component to make LAN • Cables • NICs in the PCs or other (e.g. Printers) • Hubs (Repeaters) • Switches

  8. Configure NIC • Use hotplug. • lspci , lspci -n • PCI Vendor ID. (on the Internet) • /lib/modules/<kid>/kernel/drivers/net/ • USB Cable, USB ADSL => USB NIC. • lsmod • ifconfig -a

  9. IP v4 Address • Class A 1.0.0.0-126.0.0.0 7/24 • Class B 128.1.0.0-191.254.0.0 14/16 • Class C 192.0.1.0-223.255.254.0 22/8 • Class D 224.0.0.0-239.255.255.255 • Class E 240.0.0.0-254.255.255.255

  10. IP Network and subnets • A name for IP based LAN. • IP Network – mask according to class. • IP sub network have a smaller mask. • Example: • 10.1.0.0, 255.255.0.0 is subnet class A.

  11. Address Resolution Protocol • RFC 826 • Map LAN MAC into the IP address. • Dynamic ARP. • Manual ARP • Static ARP.

  12. Linux LAN • ifconfig -a – See your interfaces • arp -n – See the ARP table • arp -s ip mac – Set ARP • route -n • ip - iproute2 tool

  13. Dst 10.101.15.73 Src 10.1.14.124 Dst MAC 00-02-BA-13-BC-11 Src MAC 00-05-1B-1A-3C-B4 IP routing. Server Router 10.101.15.1 10.1.14.1 10.101.15.73 10.1.14.124 00-02-BA-13-BC-11 00-02-BA-13-BC-13 00-05-1B-1A-3C-B4 00-02-B3-1D-5E-87

  14. Dst 10.101.15.73 Src 10.1.14.124 Dst MAC 00-02-B3-1D-5E-87 Src MAC 00-02-BA-13-BC-13 IP routing. Server Router 10.101.15.1 10.1.14.1 10.101.15.73 10.1.14.124 00-02-BA-13-BC-11 00-02-BA-13-BC-13 00-05-1B-1A-3C-B4 00-02-B3-1D-5E-87

  15. Routing table • Default Gateway. • Simple example: • Destination Gateway Genmask Flags Metric Ref Use Iface • 10.1.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0 • 0.0.0.0 10.1.0.1 0.0.0.0 UG 0 0 0 eth0

  16. A real route • RIP – RFC 1058, 1388, 1723 • OSPF - RFC 2178 (v2) • BGP - RFC 1771 (BGP-4) • PIM – RFC 2362, 3973 • OSI IS-IS • IGRP, EIGRP – Cisco. • Real routers are not just routers!

  17. PPP • Point to Point Protocol • IP protocol for connecting PC over phone line. • Use tty char device for transferring IP packets. • RFC 1661, RFC 1662 (STD 51) • HDLC ISO 3309

  18. Why PPP? • Phone lines. • Authentication. • Bandwidth and QoS control • Dynamic client to ISP mapping. • Easy configuration VPN. • Compression option. • Packets concatenating.

  19. PPP structure • LCP – Create the PPP link. • PAP or CHAPauthentication. • HDLC – Octet/Bit stuffed framing

  20. PPP over link layer • PPPoE - RFC 2516 • PPPoA – RFC 2364 • MAC address or VP instead of phone line.

  21. PPP over IP • L2TP – RFC 2661, RFC 3931 (v3) • PPTP – RFC 2637 • Server IP instead of phone number. • Two IP networks with one IP stack • Need a more complicated routing. • Possible to work L2TP over PPPoE.

  22. PPP over IP routing • Simple example: • Destination Gateway Genmask Flags Metric Ref Use Iface • 132.64.140.2 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0 • 10.1.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0 • 0.0.0.0 132.64.140.2 0.0.0.0 UG 0 0 0 ppp0

  23. Linux PPP tools • The PPP daemon • PPTP client – works with the pppd. • L2TP – status unknown. • PPPoE • PPPoA – kernel patch with ATM driver. • Kernel 2.6 - PPP, PPPoE, PPPoA